BookSmart

Locked Changing All Text Fonts at Once?

Is there a command to unify all the text in a book?  When I work on a page I keep changing the font to Times, but when I go to a new page it defaults to Georgia.  I want to be sure I didn’t let a Georgia slip by.  Thanks.

Posted by
tkcs
Jul 24, 2008 8:00am PDT
Permalink
tkcs
 

Hello tkcs;

Can’t be done in this release… unfortunately…

Blurb are promising that their next update of BookSmart – due "late summer" will have FAR better text handling functionality; but until that happens, we are stuck with reviewing each and every container individually… and it’s a royal pain in the rear !

Good luck;

Lee

Posted by
lkb-28
Jul 24, 2008 8:25am PDT
Permalink
lkb-28
 

Has anyone fixed the "default to Georgia" problem??? It is driving me crazy!

I have gone to "select style" and "customized style" it all looks good there and does nothing to my actual book.

Posted by
iamokaye
Feb 25, 2010 3:56pm PDT
Permalink
iamokaye
 

I would be very interested to know if this has been resolved too. I prefer San Serif for my text boxes and having to change the Georgia default every box is so time-consuming and tedious. I have nearly slipped up a couple of times with this. Also the size is only 8 and I like 10 and this also has to be altered each time.

Posted by
rrusty49
Feb 25, 2010 4:30pm PDT
Permalink
rrusty49
 

Yes, Georgia is a font I would never use, despite Booksmart’s urging. It would be nice if BS let you define your own default font. The best practice I have managed to devise is to make sure every one of your text boxes is labeled “Caption” or “Heading 1” or one of the other styles that BS has predefined. Then define these styles (Customize Styles…) with the font (and size and color) you want to use.

Unfortunately there is no way I have found to create your own named styles, so you may have to use some styles that are not really appropriate to the kind of text you are tagging. But no matter, just use them. No one will know that you used “Heading 2” for quotations. Then, when you are beset by an attack or Georgiaitus, re-apply the style name to the text container.

If you copy a page and paste it to create a new page, the text containers will inherit the styles from the page you copied. If you add a page by clicking on a page layout from the array presented at the upper left, you will have to define the style for each text box on the new page.

In other news: If you have a header that is set to be different for each chapter, keep an eye on it. Twice I have had the header default to the same text for every chapter.

Posted by
jshook
Feb 26, 2010 7:17am PDT
Permalink
jshook
 

Thanks js

Posted by
rrusty49
Feb 26, 2010 11:09am PDT
Permalink
rrusty49
 

Click on the window under Edit Layout in upper left corner of page view. Scroll down to Customized Styles. No window will open where you can insert the font /size you want in each of the different tex boxes: caption, header, footer, heading, body, caption.

Posted by
loricherokee
Mar 3, 2010 9:11am PDT
Permalink
loricherokee
 

Hi lori,

Thanks for the advice, I tried what you suggested but it just opened up the book in the grey mode (the Customised Styles never opened as an option, it just went straight to the grey mode), and I couldn’t find a Customised Styles anywhere. Am I still doing it wrong?

rrusty

Posted by
rrusty49
Mar 3, 2010 9:56am PDT
Permalink
rrusty49
 

Put me in the list of people who will applaud getting this fixed. This has been a big problem.

Posted by
Paulsson
Mar 5, 2010 3:15am PDT
Permalink
Paulsson
 

My workaround would be use a text editor to open the .book file (which is a XML file), and replace every “Georgia” with the font you want. Works fine on my mac.

Posted by
victorworld
Jun 17, 2010 7:13am PDT
Permalink
victorworld
 

Hi victoriaworld,

Nice find. As you can probably guess, we cannot recommend modifying the .book file itself as doing so may result in a corrupted file.

That said, the same can be achieved within BookSmart by navigating to the Styles dropdown found in the text menu bar (when text is selected). Choosing "Customize Styles" will then allow multiple text containers to be modified at once.

Note: Locking thread due to age and outdated information.

-Craig

Posted by
csm
Jun 17, 2010 10:03am PDT
Permalink
csm Icon_staff