BookSmart

Bugs in 2.9 - two monitors, pane status

I have noted this before and will do it again. I work with two monitors and would love to run Booksmart on my second and larger screen, but very time I apply a layout it shifts back to the primary screen. Very annoying! I’m NOT after a "two screen mode" but jkust want the program to stay where I put it!

I’m also annoyed by the fact that I constantly have to disable the panes "Content library", "Apply page layout" and "Page navigator" to get a full screen view. Booksmart keeps turning them on again when I apply a layout. That must definitely be considered a bug!

The program ought to save my setup and recreate the exact screen every time I return to my work screen – even after restarting the program.

As a side not I can warmly recommend to add a shortcut to toggle all panes (Like Photoshop’s use of the Tab key) . At the same time you could at shortcuts to hide and show them individually.

I would also love to see a linked text frames feature. This only seems to be available in the predefined layouts where the frames are locked. The basic function is obviously somewhere in the deep, but I can’t control it sufficiently to make it really useful.

I generally like the program, and I’m in the process of making my fourth and fifth book. Keep up the good work.

Martin



Replytopic_b_normal
Posted by
MartinJ
Sep 30, 2010 5:33am PDT
Permalink
MartinJ
 

As a supplement to the above remarks, I can add the the "Page navigator" pane also gets enabled when I change Page View by clicking the symbols to the right under my book. If I am in single page mode and click single page, the Page Navigation appears in spite of the fact that nothing at all should happen!

Almost the same thing happens when using the menu or the shortcut keys (Ctrl-1-2-3) to change view mode apart from selecting the current view mode, which has nof effect… as expected.

Martin

Posted by
MartinJ
Oct 3, 2010 9:35am PDT
Permalink
MartinJ
 

I second this. I also have this problem with a two monitor setup in BookSmart 2.9.1. The window shifts back to the primary screen after I edit a layout. It’s very annoying.

I also noticed that the panes come back after being hidden and that the “Page navigator” pane becomes very narrow (to the point where no thumbnails can be seen) after I come back from editing a layout and shifting the window back to the second monitor.

Posted by
maxkhaskin
Oct 19, 2010 1:44pm PDT
Permalink
maxkhaskin
 

I have now moved to a new computer system and the latest version of Booksmart (3.2) and I simply cannot believe that this hasn’t been fixed!

IT’S EXTREMELY ANNOYING

I have a large second monitor, and maximizing the program to utilize it makes the work SOOOO much easier. But I simply can’t edit the layout! As soon as I do that the whole program flips back to the smaller screen and reinstates all the previously disabled panes!

SHEESH! How difficult can it be to save the user’s UI choices and leave the bleedin’ window where it is? It’s a really counterproductive and fundamental flaw in the software, and very close to making me quit my project and find some other way to make my book.

Please, developers! Do something about this. Please!

Martin

Posted by
MartinJ
Feb 28, 2012 10:07am PDT
Permalink
MartinJ
 

Hi Martin,

Agreed that this is an annoying problem if you use a multi-monitor setup. We prioritize bugs partially based off feedback from our help center, and I must admit this is not something many users contact us about. We’ve looked into the problem and it proved to not be as easy a fix as one might think.

I encourage others that have the same problem to let us know so that we may re-prioritize the bug.

-Craig

Posted by
csm
Feb 28, 2012 12:07pm PDT
Permalink
csm Icon_staff
 

Craig,

Thanks for your reply. Being a software developer myself, I realize that such problems are not always easy to fix, but being a software developer I also know that when programs act like this and it can’t be fixed, there’s somthing fundamentally wrong…

And the problem is not a two monitor issue only. The page navigator consistently pops back after I disable it, go into edit mode and apply or cancel the edit. Now that’s a bug! 

Right now I just did this:
1) Enabled the Page navigator and set it to a suitable size
2) Enabled the Content Library (which also enables the Apply page layout although it’s a separate menu item = bug)
3) Disabled the Content Library Apply page layout (has to be done separately)
4) Went into edit mode (Ctrl-E)
5) Cancelled

This reenabled both left side tools and made the page navigator so small it is invisible.

Whatever combinatios of enabling and diabling I do, it seems that BookSmart will return to a different state after I leave edit mode.This has nothing to do with using two monitors, but is consistent on a single screen and can bereplicated time after time in the different strange patterns.

Saving  the user’s choices and reestablishing the workspace accordingly shouldn’t be rocket science…

Martin

 

Posted by
MartinJ
Feb 29, 2012 2:29pm PDT
Permalink
MartinJ
 

Hi Martin,

The page navigator bug is being addressed and will hopefully be fixed in the next major release of BookSmart later this year.

-Craig

Posted by
csm
Mar 1, 2012 9:26am PDT
Permalink
csm Icon_staff
 

Craig,

Thanks for the reply. SMall improvements are also improvements! I’ll be looking forward to the next update.

And thanks for an excellent service. In spite of mymoaning about the software, I still enjoy every book I make!

Martin

Posted by
MartinJ
Mar 2, 2012 2:40am PDT
Permalink
MartinJ
 

And could you at the same time tell the Web-folks that the editor they use have a fundamental flaw: it eats and adds spaces as it pleases!

Press enter to get a new (emtyp) line, and you get a free space character at the end of the line!

If you on the other hand leave a space at the end of a line, press enter and then backspace, that space character disappears.´But of course you still have the free one that the editor added – it’s just at the end of the line, and not where you expect… ;-)

Martin

 

Posted by
MartinJ
Mar 2, 2012 2:48am PDT
Permalink
MartinJ